Jump to content
Sign in to follow this  
webtom

APU + Win10

Recommended Posts

Cześć,

ostatnie dwa wieczory męczę się z dziwnym problemem i jako że nie mam pomysłów, jak go rozwiązać, to zwracam się do Was.

Sprawa wygląda następująco - jako że od jakiegoś czasu miałem zbędnego SSD (MX100 256GB), to postanowiłem przekazać go mojemu tacie, coby nieco usprawnić jego maszynkę (jej specyfikacja to A8-3870 + GA-A75M-S2V + 2x4GB RAM + jakiś Chieftec 350W, całość podłączana do monitora FullHD 22'' z użyciem przejściówki DVI -> HDMI i kabla HDMI).

System to (jak w temacie) Windows 10 - utworzyłem obraz ISO, wrzuciłem na pena, odłączyłem oba dyski (systemowy WD Green 1TB + jeszcze jakieś 320GB), podpiąłem SSD, zainstalowałem 10tkę, przez Menedżer urządzeń -> Aktualizuj oprogramowanie sterownika zainstalowałem sterowniki do karty, uruchamiam ponownie, pojawia się niebieskie logo Windowsa na czarnym tle z kręcącymi się kółeczkami w dolnej części ekranu, obraz na czernieje, po chwili logo powraca i zaczynają się kłopoty - już nawet kręcące się kółeczka mają wyraźne problemy z płynnością, dotarcie do pulpitu zajmuje dobre pół minuty, przez dobrych kilka minut dysk jest stale obciążony w 100%, cały system ma poważne problemy z płynnością, nawet kursor przesuwa się po ekranie w trybie skokowym. W takim razie DDU -> przejście do trybu awaryjnego (od razu znikają problemy z wydajnością) -> odinstalowanie sterowników (DDU rzucił jakimś komunikatem, że wyłącza automatyczne wgrywanie sterowników przez Windowsa) -> ponowne uruchomienie. Wizyta na stronie AMD w poszukiwaniu sterowników wiele nie dała (klik), w Menedżerze zadań widnieje jakaś tam Standardowa karta graficzna, a wybranie Aktualizacji sterowników nic nie daje, bo system twierdzi, że te są aktualne. No ale że rozdzielczość ekranu była daleka od ideału (i płynność samej grafiki pozostawia nieco do życzenia), to spróbowałem jeszcze skorzystać z narzędzia od AMD do automatycznego wykrywania sterownika. Przy instalacji odznaczyłem Gaming Evolved i inne zbędne bzdety (właściwie wszystko, co się dało i nie było sterownikiem), efekt był taki, że zainstalowało się wszystko poza sterownikiem smile_prosty.gif

Jeszcze trochę poklikałem, ale wiele to nie dało, więc uznałem, że postawię system jeszcze raz - doszedłem do ponownego uruchomienia po instalacji sterowników i ponownie powitał mnie problem z wydajnością. Postanowiłem zmienić strategię - postawić system jeszcze raz i nie przejmować się sterownikiem do karty. Udało mi się zainstalować Chrome'a, a w międzyczasie system sam zaczął instalować sterowniki do karty (w pewnym momencie nastało FullHD), potem przyszedł czas na Office'a i kilka pomniejszych programików. Uznałem, że czas ponownie uruchomić system (który stale był w swoim pierwszym pełnym uruchomieniu i sprawował się bez najmniejszych zarzutów), no i naturalnie po restarcie wszystkie problemy powróciły.

Z ciekawszych obserwacji - przy wyłączaniu komputera komputer pracował jeszcze przed kilkadziesiąt sekund z wyłączonym ekranem i głośno pracującymi wentylatorami.

Odłączyłem SSD, podłączyłem HDD, system wstał i żadnych większych problemów z płynnością nie ma (tzn. jest miernie, czyli tak jak zawsze).

Pozostaje jeszcze problem z wyświetlaniem tapety - w którymś momencie (chyba gdzieś po odinstalowaniu sterowników za pomocą DDU) zamiast normalnego obrazka pojawiło się coś takiego. Co prawda po zabawach ze zmianą tapety problem znika, ale najdziwniejsze jest to, że to samo zaczęło występować również na systemie z HDD, gdzie wcześniej żadnych takich cudów nie było, no i problemów z wydajnością brak.

tl;dr Windows 10 po zainstalowaniu sterowników do karty graficznej ma problemy z płynnym działaniem.

Garść screenów ze specyfikacją:

image.jpgimage.jpgimage.jpgimage.jpgimage.jpgimage.jpg

Share this post


Link to post
Share on other sites

Ogólnie odpowiedź jest tu - pod żadnym pozorem nie należy instalować sterowników od AMD, bo skończy się to źle. Sterowniki z Windows Update powinny działać prawidłowo, ale widać, że jednak nie działają. Z drugiej strony problem może być powodowany przez jakiś inny sterownik. Najlepiej byłoby przeanalizować logi systemowe i być może wtedy się coś znajdzie. Jeśli tam nic nie ma, to będzie trudno.

W zależności od zastosowań kompa można też pomyśleć o jakimś Linuksie. Prawdopodobnie będzie to mniej problematyczne wyjście.

Share this post


Link to post
Share on other sites
Z drugiej strony problem może być powodowany przez jakiś inny sterownik.
Biorąc pod uwagę fakt, że problemy za każdym razem pojawiały się bezpośrednio po instalacji sterownika graficznego, no i zniknęły po jego odinstalowaniu (przynajmniej tak było przy pierwszej instalacji, później nie sprawdzałem), to jednak wydaje mi się to całkiem dobry trop.

Wczoraj wieczorem natrafiłem na dosyć dziwne zachowanie - odpalam kompa, a on działa szybko. Sekwencja kolejnych uruchomień wyglądała jakoś tak: Szybko/Wolno/W/S/W/S/W/W/W (i dałem sobie spokój). Oczywiście próbowałem zarówno ponownych uruchomień, jak wyłączeń/włączeń, jednak żadnej korelacji z szybkością działania systemu nie zaobserwowałem.

Najlepiej byłoby przeanalizować logi systemowe i być może wtedy się coś znajdzie.
Z czystej ciekawości - czego i gdzie powinienem szukać?

I jakbyś miał pomysł, skąd mogło się wziąć niedeterministyczne szybko-wolne działanie, to może kiedyś najdzie mnie ochota, żeby to jeszcze nieco potestować.

W zależności od zastosowań kompa można też pomyśleć o jakimś Linuksie. Prawdopodobnie będzie to mniej problematyczne wyjście.
Sądzę, że większe szanse miałby dowolny Windows, pewnie nawet XP.

Ale sugestia, żeby spróbować innego systemu podsunęła mi inny pomysł, który generalnie jest głupi, ale przynajmniej już wcześniej zadziałał (na systemie z HDD) - instalacja Win7 i upgrade do 10tki. I tym razem też się udało smile_prosty.gif

Jakbyś chciał się jeszcze podzielić jakąś uwagą, to chętnie ją przeczytam, jeżeli nie - temat niedługo zamknę.

Share this post


Link to post
Share on other sites
Z czystej ciekawości - czego i gdzie powinienem szukać?

Przede wszystkim warto zajrzeć do Poglądu zdarzeń i posprawdzać, czy nie występują jakieś błędy. Najważniejsze w tym przypadku będą dzienniki Aplikacji oraz System.

I jakbyś miał pomysł, skąd mogło się wziąć niedeterministyczne szybko-wolne działanie, to może kiedyś najdzie mnie ochota, żeby to jeszcze nieco potestować.

Niestety nie za bardzo mam pomysł. APU z tamtej serii w ogóle potrafiły dziwnie się zachowywać, co w pewnych przypadkach było winą AMD, a w pewnych producentów płyt głównych. Warto poszukać na zagranicznych forach, może ktoś się natknął na podobny problem.

Sądzę, że większe szanse miałby dowolny Windows, pewnie nawet XP.

Sterowniki do kart AMD, wbrew obiegowym opiniom, wcale nie działają jakoś tragicznie pod Linuksem. Zazwyczaj działają gorzej niż te nVIDII, ale problemy sprawiają jedynie w grach. Większe problemy zdarzają się tak naprawdę jedynie z naprawdę świeżymi kartami, bo zazwyczaj na ich poprawne wsparcie trzeba poczekać parę miesięcy.

Share this post


Link to post
Share on other sites

Ok, może kiedyś spróbuję co nieco pokombinować, ale że obecnie na SSD jest sprawny system i musiałbym organizować jakiś inny dysk (najpewniej jakiś HDD), to chwilowo brakuje mi motywacji smile_prosty.gif

Co do Linuxa - nie chodzi o sterowniki, a o operatora wink_prosty.gif

Jako że problem już rozwiązany, to temat zamykam.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...