Jump to content

Archived

This topic is now archived and is closed to further replies.

radekkut

GTA 4

Recommended Posts

Mam problem z GTA 4, zacząłem grać niedawno (nowy komp :)).

Problem z misją u Bruciego "Znajdź i usuń". Po wejściu do komputera policyjnego, wpisaniu nazwiska i przeszukaniu bazy

wywala mnie do Windows z komunikatem "wystąpił błąd i aplikacja zostanie zamknięta".

Niby nic nowego, ale próbowałem 3 razy, za każdym razem to samo (w dokładnie tym samym miejscu!) + za 3 razem blue screen :/

Ma ktoś pomysł?

Z góry dzięki

Link to comment
Share on other sites

Tak, gra działa na luzie, grafa może trochę słaba, ale płynnie.

I muszę sprostować - to jest misja dla Bruciego, nie Jacoba.

Zrobiłem skan kompa, nic.

Spróbuje przy wyłączonych antivirach.

Acha, to jest pierwszy raz, jak mi się z GTA 4 coś takiego zrobiło. Reinstal to tylko w ostateczności ;)

Link to comment
Share on other sites

Jeśli pojawił się blue screen to standardowo:

Więc tak, pierwsze co musimy wiedzieć to jaki plik/program powoduje błąd krytyczny w systemie. Do tego bedzie potrzebny nam swego rodzaju log. Mozna go uzyskać w ten sposób :

Do rzeczy. Pierwszym krokiem jaki musimy zrobić będzie ściagniecie i zainstalowanie Microsoft Debugging Tools, który znajdziecie tutaj: CLICK

Gdy juz zainstalowaliście program wchodzimy: Start - Programy - Debugging Tools For Windows - WinDbg.exe

Otworzy nam sie okienko programu. Zobacz Foto

Klikamy na File - Open Crash Dump (Ctrl+D)

Teraz musimy odszukać nasz plik dumpa. Standardowo Windows XP zapisuje je sobie w %systemroot%/minidump (w moim przypadku jest to c:\windows\minidump) i tam wlasnie nalezy ich szukać. Zobacz foto

Pliki te posiadaja unikalną nazwę, na przyklad: Mini121504-01.dmp

Możemy z tego dowiedzieć sie że nasz problem musiał wydażyć sie wlaśnie dzisiaj, czyli 15 grudnia 2004.

Gdy juz wiemy gdzie znaleźć nasz plik otwieramy go w naszym Debbugerze. Jeśli wyskoczy nam okiengo o Zapisaniu naszego Miejsca pracy (Save Workspace) najlepiej wybrac No. Zobacz Foto

Teraz naszym oczom ukaże się magiczna informacja. Z początku może byc to dla nas bardzo niezrozumiałe ale po przeczytaniu kilku wierszy zostaniecie oświeceni.

Tą ,,magiczną informacje'' zapodaj nam tutaj a dowiemy się co powoduje crash systemu.

Link to comment
Share on other sites

Na pewno chcesz całe?

Loading Dump File [C:\WINDOWS\Minidump\Mini081609-01.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

Symbol search path is: *** Invalid ***
****************************************************************************
* Symbol loading may be unreliable without a symbol search path.           *
* Use .symfix to have the debugger choose a symbol path.                   *
* After setting your symbol path, use .reload to refresh symbol locations. *
****************************************************************************
Executable search path is:
*********************************************************************
* Symbols can not be loaded because symbol path is not initialized. *
*                                                                   *
* The Symbol Path can be set by:                                    *
*   using the _NT_SYMBOL_PATH environment variable.                 *
*   using the -y <symbol_path> argument when starting the debugger. *
*   using .sympath and .sympath+                                    *
*********************************************************************
Unable to load image \WINDOWS\system32\ntkrnlpa.exe, Win32 error 0n2
*** WARNING: Unable to verify timestamp for ntkrnlpa.exe
*** ERROR: Module load completed but symbols could not be loaded for ntkrnlpa.exe
Windows XP Kernel Version 2600 (Service Pack 3) MP (2 procs) Free x86 compatible
Product: WinNt
Machine Name:
Kernel base = 0x804d7000 PsLoadedModuleList = 0x8055d720
Debug session time: Sun Aug 16 13:22:37.078 2009 (GMT+2)
System Uptime: 0 days 0:21:18.659
*********************************************************************
* Symbols can not be loaded because symbol path is not initialized. *
*                                                                   *
* The Symbol Path can be set by:                                    *
*   using the _NT_SYMBOL_PATH environment variable.                 *
*   using the -y <symbol_path> argument when starting the debugger. *
*   using .sympath and .sympath+                                    *
*********************************************************************
Unable to load image \WINDOWS\system32\ntkrnlpa.exe, Win32 error 0n2
*** WARNING: Unable to verify timestamp for ntkrnlpa.exe
*** ERROR: Module load completed but symbols could not be loaded for ntkrnlpa.exe
Loading Kernel Symbols
...............................................................
................................................................
......
Loading User Symbols
Loading unloaded module list
.......
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

Use !analyze -v to get detailed debugging information.

BugCheck A, {54, 1c, 1, 80502cc0}

*** WARNING: Unable to verify timestamp for mssmbios.sys
*** ERROR: Module load completed but symbols could not be loaded for mssmbios.sys
***** Kernel symbols are WRONG. Please fix symbols to do analysis.

*************************************************************************
***                                                                   ***
***                                                                   ***
***    Your debugger is not using the correct symbols                 ***
***                                                                   ***
***    In order for this command to work properly, your symbol path   ***
***    must point to .pdb files that have full type information.      ***
***                                                                   ***
***    Certain .pdb files (such as the public OS symbols) do not      ***
***    contain the required information.  Contact the group that      ***
***    provided you with these symbols if you need this command to    ***
***    work.                                                          ***
***                                                                   ***
***    Type referenced: nt!_KPRCB                                     ***
***                                                                   ***
*************************************************************************
*************************************************************************
***                                                                   ***
***                                                                   ***
***    Your debugger is not using the correct symbols                 ***
***                                                                   ***
***    In order for this command to work properly, your symbol path   ***
***    must point to .pdb files that have full type information.      ***
***                                                                   ***
***    Certain .pdb files (such as the public OS symbols) do not      ***
***    contain the required information.  Contact the group that      ***
***    provided you with these symbols if you need this command to    ***
***    work.                                                          ***
***                                                                   ***
***    Type referenced: nt!_KPRCB                                     ***
***                                                                   ***
*************************************************************************
*********************************************************************
* Symbols can not be loaded because symbol path is not initialized. *
*                                                                   *
* The Symbol Path can be set by:                                    *
*   using the _NT_SYMBOL_PATH environment variable.                 *
*   using the -y <symbol_path> argument when starting the debugger. *
*   using .sympath and .sympath+                                    *
*********************************************************************
*********************************************************************
* Symbols can not be loaded because symbol path is not initialized. *
*                                                                   *
* The Symbol Path can be set by:                                    *
*   using the _NT_SYMBOL_PATH environment variable.                 *
*   using the -y <symbol_path> argument when starting the debugger. *
*   using .sympath and .sympath+                                    *
*********************************************************************
Probably caused by : ntkrnlpa.exe ( nt+2bcc0 )

Followup: MachineOwner

EDIT: To ntkrnlpa.exe znalazłem w... UWAGA... C:/windows/system32.

EDIT2: Próbowałem jeszcze raz, znowu wyłączyło GTA, ale blue nie było... A zdaje się, że ta misja jest niezbędna :/

Link to comment
Share on other sites

Problemy z jądrem systemu.. Podaj temperatury karty procesora, a takze przeczysc kompa np Ccleaner'em oraz Kasperskyp. Możesz także spróbować takiego coś: .mój komputer - właściwości - zaawansowane - raportowanie błędów - zaznacz wyłącz raportowanie błędów i odznacz powiadom mnie,gdy wystąpią błędy krytyczne

Bedziemy próbować, ewentualnie moge ci zapodać save z 25% gry.

Link to comment
Share on other sites

Dzięki, save nie chce, problem tylko w tym, że (nie wiem, czy czytałeś), blue screen i wywalanie GTA nie mają chyba zbytniego powiązania :/

Cóż, zainstalowałem patcha 1.0.0.4 i to samo, tylko że od razu po wczytaniu zapisu :/

Wyłączyłem raporty, jutro sprawdzę, czy będzie działać.

Link to comment
Share on other sites

A na jakich detalach grasz w GTA?

Bo jak ja grałem w jakąś grę na najwyższych detalach to nagle zwiecha, BSOD i restart kompa. Zmiana detali na niższe pomogła ;)

Gram na bardzo niskich, bo karta nie wydala wysokich (256MB).

Cleaner nie pomógł, spróbuje kasperskym...

Kaspersky też nic nie dał :'(

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.


  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...