Jump to content

Archived

This topic is now archived and is closed to further replies.

Skreedi

BATTLEFIELD Bad Company 2 i Windows 7

Recommended Posts

Kolejny zgrzyt po przesiadce z Visty na Siódemkę, najpierw Gothic z którym nie da się nic zrobić, a teraz BF... Po paru minutach gry komputer się wiesza z powtarzającym się dźwiękiem. W tej sytuacji zostaje tylko reset komputera. Próbowałem uruchamiać grę ze zgodnościami, jako administrator, pliki od sterowników ustawiłem "Uruchom jako administrator" (tak ludzie piszą na forach, podobno pomaga...) jednak to nic nie dało, nadal zacina mi komputer. Co mogę jeszcze zrobić?

Link to comment
Share on other sites

CPU: Intel Core2Quad Q6600 2.4Ghz@3.24Ghz

GPU: MSI GTX460 1GB

MOBO: GIGABYTE EP45-DS3R

PSU: TAGAN 600W

RAM: OCZ 4GB DDR2 1066Mhz

OS: Widnows 7 Ultimate x64

Proszę bardzo, dodam jeszcze, że aktualizowałem sterowniki karty dźwiękowej (przeczytałem na forum EA w sprawie tego zawieszania) i zaznaczyłem "Uruchom jako administrator" jednak nadal nic... Wcześniej na Viście x64 nie było żadnych problemów.

Link to comment
Share on other sites

Spróbuj pobrać najnowszego patcha ma okolo 2.4GB :) Podobno pomaga ;)

Co do twojego posta sebawilk, skoro to by była tego wina to skutki by były na Viście którą miał wcześniej :)

Z tego co pisał to wtedy nie było takich problemów.

Link to comment
Share on other sites

Najnowszego patcha? Tego co ma w sobie Vietnam? Jeśli tak to już go mam, od razu po instalacji włączyłem Updatera tak więc gra jest aktualna. Co do OC to na pewno nie to, wcześniej na Viście przeszedłem GTA IV, Metro 2033, Crysis 2, gry więcej wymagające od BC2 i nic się nie działo, teraz na Siódemce przeszedłem Gothica 3 i też nic nie wywalało. Wina musi leżeć w sofcie - grze lub sterownikach jak piszą na różnych forach.

Link to comment
Share on other sites

Faktycznie moja gafa :wallbash:

Moje pomysły:

- Wyłącz może kartę dźwiękową i zobacz czy nadal będzie się wieszało.

- wgraj od nowa sterowniki do wszystkiego grafiki, dźwiękówki, directX, procesora [amd mają takowe]

- Od taktuj wszystkie komponenty

- ostatnia możliwość masz pecha ;p przesiądź się na windows vista 64bit lub zrób reinstal ; ]

ps. lub win 7 się zepsuł [ na mojej 7-ce nie mogę włączyć żadnego benchmarku 03, 06, ventege i 2011 bo jakiegoś pliku niby nie może znaleźć a wcześniej działało bez problemu :P ]

Link to comment
Share on other sites

przesiądź się na windows vista 64bit lub zrób reinstal ; ]

tja, najlepiej niech od razu przestanie grać i przerzuci się na telewizję ;)

Ok, wczoraj siedziałem nad tym cały dzień i myślę, że udało mi się rozwiązać problem. Rzecz w tym, że robiłem pare rzeczy więc nie wiem która pomogła ale obstawiam stery od dźwięku. W menedżerze urządzeń odinstaluj sterowniki od karty dźwiękowej (ja mam Realtek, płyta też Gigabyte), uruchom ponownie komputer. Windows 7 (nie wiem jak reszta) zainstaluje Ci stery samoczynnie.

Co poza tym zrobiłem:

- reinstalowałem grę z usuwaniem pozostałych plików (oprócz ustawień), usunąłem całkowicie PB, po instalacji gry zaktualizowałem Setupem PB ze strony EB.

- w dokumentach w folderze gry w settings ustawiłem speakercount=2 (nie zmieniłem tego niestety z powrotem przed odinstalowaniem sterowników także nie wiem czy to rzeczywiście jest wymagane)

Dziś grałem 2h z jednym zawieszeniem kompa (normalnie restart musiałem robić po 5-30min, ale najczęściej po ok 5min), mam nadzieję, że to z innego powodu. Poza tym wszystko działa.

Przed tym próbowałem m.in. grać bez dźwięku (dźwiękówka wyłączona w menedżerze urządzeń), lecz i tak gra się zawiesiła. Kombinowałem z wieloma sposobami znalezionymi w necie (np. BES, podmienianie plików PB itd), nic nie pomagało.

Jeżeli problem u mnie wróci, napiszę o tym.

Link to comment
Share on other sites

@up

Dzięki, zaraz spróbuję twojego sposobu.

@top

Sam też kombinowałem i zastosowałem się do tej instrukcji

Hi guys.. im back

It looks like Im not getting soundloop crash anymore.

Please help me test my Fix with your systems.

Instructions:

1. Manually UNINSTALL PB using the installer from you BC2 original CD

E:\PunkBuster\pbsvc_bc2.exe

2. Manually delete the files left behind as mentioned by Von Dach's

3. Run sfc /SCANNOW in both system32 and Syswow64 folders

[use windows powershell not the CMD ] this is to fix the curropted files after all those freezes and this will take 30 minutes for both folders.

4. Reinstall Audio drivers Using the R2.51 drivers from realtek [Driver date is as of August 3 2010].

5. Reisntall PB service ... the usual way .. make sure you update it and pointing to the BC2 folder

6. Locate the Punkbuster Programs in C:\Windows\system32

locate " PnkBstrA.exe and PnkBstrB.exe"

7. If you can see these two... right click on both and Select the Compatibility Tab.

From there you must set It to Always run as Admin and Set the compatibility to Windows XP Service pack 3.

[Correct me if Im wrong..I think Punkbuster's defects arise with the recent BC2 patch... and makes it crash in windows7systems]

8. Restart your system.

Please try it now and reply to this thread... [screw EA, PB, and Realtek ]

Link do tematu: http://forum.ea.com/eaforum/posts/list/1696952.page

Niestety to nie pomogło, teraz biorę się za sposób Niko90. Co do przerzucenia się na Vistę to NO WAI, ponieważ mi wygasła ;d

Link to comment
Share on other sites

To będzie tak:

Start -> cmd -> i wpisujesz sfc /scannow.Po tej operacji restartujesz komputer wchodzisz do trybu awaryjnego wywalasz stare sterowniki o dźwięku, restart instalujesz najnowsze dostępne, odpalasz sobie spokojnie kompa i teraz tak.Znwou Start -> msconfig -> i w uruchamianiu szukasz Menadżera Realteka bo na 80% posiadasz jeżeli masz ten problem.Po tej operacji zostaje tylko jedno.Wchodzisz do panelu sterowania -> Dźwięk -> Otwierasz Realtek Mendadżer HD Audio ( czy jakoś tak ) i tam w zakładce Głośniki szukasz pod zakładki Domyślny format i zmieniasz na jakość 16 bit 48000Hz.Zamykasz Menadżera, Wyłączasz go w Menadżerze zadań i bez żadnej zgodności i administratora odpalasz grę.U mnie działa elegancko.Pozdrawiam.

Ten sposób działa na 85% takich problemów u innych graczy.

@up Przepraszam jeszcze PunkBuster.Wywalasz PunkBustera starego kompletnie (spr. czy w folderze z grą nie został i w folderze X:\Users\Twoja_nazwa\AppData\Local\Punk Buster i wtedy ten folder też wyrzuć) Najlepiej odinstalować go przez instalke na płycie od BC2.Pobierasz instalkę z neta i instalujesz wybierając daną grę.Koniec pieśni :)

Link to comment
Share on other sites

Przeinstalowałem grę, zainstalowałem najnowsze sterowniki, wywaliłem wszystkie pliki PB i zainstalowałem go z Setupu ze strony oficjalnej, ustawiłem jakość na 16bit 48000Hz i w tej chwili aktualizuję grę. Dopiero wieczorem dam znać czy pomogło bo na razie muszę lecieć.

Link to comment
Share on other sites

Co do aktualizacji proponuję Ci na przyszłość ściągnąć ręcznie z internetu ten patch :) Żebyś nie musiał non stop czekać aż Ci zaktualizuje przed Updater.

A jeśli chodzi o sposoby podane wyżej... działają i powinny w twoim przypadku pomóc mi pomogły jednakże ja mam Windowsa XP HE ;-)

Link to comment
Share on other sites

Przeinstalowałem grę, zainstalowałem najnowsze sterowniki, wywaliłem wszystkie pliki PB i zainstalowałem go z Setupu ze strony oficjalnej, ustawiłem jakość na 16bit 48000Hz i w tej chwili aktualizuję grę. Dopiero wieczorem dam znać czy pomogło bo na razie muszę lecieć.

Niestety nie pomogło... Macie jeszcze jakieś pomysły? :/

Link to comment
Share on other sites

A wyłączyłeś Realtek HD Audio Menadżer?Weź jeszcze ten cmd -> sfc /scannow i może zmień renderowanie na DirectX 9.Ustawiasz to w Dokumenty/BFBC2/settings (otwierasz notatnikiem) i szukasz linijki Dxversion=x Zamiast X wpisujesz 9.

Link to comment
Share on other sites

Patrzę na dużą liczbę postów w tym temacie, skomplikowane rozwiązania a tu brak najprostszego. Pełno specjalistów, którzy nie mają pojęcia co piszą. Zawsze na win 7 z każdym problemem włączam jako Administrator lub uruchamiam tryb zgodności. To takie proste rozwiązanie a tak późno na nie wpadłeś. Pozdrawiam wszystkich... I nie zniechęcaj się jednym wywaleniem lub dwoma. Czasami mogą wystąpić. Ważne jeżeli nie powtarza się to regularnie.

Link to comment
Share on other sites

Patrzę na dużą liczbę postów w tym temacie, skomplikowane rozwiązania a tu brak najprostszego. Pełno specjalistów, którzy nie mają pojęcia co piszą. Zawsze na win 7 z każdym problemem włączam jako Administrator lub uruchamiam tryb zgodności. To takie proste rozwiązanie a tak późno na nie wpadłeś. Pozdrawiam wszystkich... I nie zniechęcaj się jednym wywaleniem lub dwoma. Czasami mogą wystąpić. Ważne jeżeli nie powtarza się to regularnie.

Próbowałem tego, nie pomogło.

Niestety i mój sposób zawiódł. Pomogło ale krótkoterminowo. Grałem dzisiaj z 5h bez problemu (z jedną przerwą), niestety wieczorem problem wystąpił znowu.

Link to comment
Share on other sites

Jakbym tylko miał dostęp do Twojego kompa to bym to zrobił :/ Zrób to co napisałem od początku do końca (2 posty) po kolei bez żadnych zgodności itp. po prostu przeinstaluj całą grę i zrób to co napisałem, a na 80% zadziała.Wg. mnie robisz coś nie po kolei albo nie tak jak trzeba.Karta trochę ciepła, ale to raczej nie powoduję problemów.

Link to comment
Share on other sites

Dobra, zrobię to jeszcze raz, dokładnie tak jak opisałeś. Dodatkowo odkurzę budę w środku. Wiem, że to raczej nic nie da bo temperatury są w normie ale przynajmniej będę pewny, że to soft...

//Po 40 minutach gry mnie nie wywaliło co jest dziwne bo wcześniej po tym samym zabiegu po 5 minutach już resetowałem komputer... Jest tylko pewien problem. Po zmianie DX z auto na DX9 mam mniej FPS'ów (x.X). Na Heavy Metalu wcześniej miałem 40-70FPS, a teraz max to 50FPS...

Link to comment
Share on other sites

Chyba cieszyliśmy się za wcześnie... na DX9 jak i na auto gra jak wywalała tak wywala nadal... Zauważyłem też, że po resecie częstotliwość procesora zjeżdża na defaultowe taktowania, a po wejściu w BIOS wyskakuje komunikat, że jest problem z taktowaniami. Robiłem sobie nadzieję jednak nawet po zostawieniu defaultowych (z 3.25Ghz na 2.4Ghz) i tak gra zacina mi komputer...

Link to comment
Share on other sites

Może zaktualizuj BIOS? Dalej... Windows 7 oryginalny :P? Spadki w taktowaniu rzadko mi się takie coś zdarzało, sprawę załatwiało reinstalowanie sterowników do procka. Nie powinno tak się dziać że procesor " puchnie".

Może byś sobie odpuścił jednak z tą "7" i wrócił na Viste skoro nie miałeś problemów?

Link to comment
Share on other sites



  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...